It is currently Sat Jul 04, 2020 1:21 pm



Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: 07 hammerhead electrical and mechanical issues
PostPosted: Wed Jun 03, 2020 11:22 am 
Offline
Probie

Joined: Wed Jun 03, 2020 11:01 am
Posts: 1
hi I'm new to this group and the hammerhead world. I just bought my kids a 07 hammerhead 250. I got it running and took my kids out last night for a rip the machine started many times in a few hours of riding I went to load it once i got it on the trailer shut it off went to start it to move it ahead a bit and nothing. Tried to start it turn the key on no power to the speedo gauge no lights and completely dead at the key. I tested the battery showed 12.9v I seen on other sites that this is not uncommon but none have any reply's on a fix. Theres one more mechanical issue in low gear the buggy makes a clunking sound like the chain is jumping but doesnt do this in high gear. Any help would be greatly appreciated

Thanks


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group

blackLevel designed by GrafsS



phpBB SEO
© Buggynews.com - All Rights Reserved