BuggyNews Buggy Forum
https://buggynews.com:443/

Kandi 150cc ignition starting issue
https://buggynews.com:443/kandi-150cc-ignition-starting-issue-t51157.html
Page 1 of 1

Author:  Mayito88 [ Mon Nov 09, 2020 10:50 pm ]
Post subject:  Kandi 150cc ignition starting issue

I'm having a starting issue with this Kandi Batman 150cc Buggy.... it won't make any sounds from the key switch... and won't turn on... the key switch has current because the neutral light turn on...at least has current on 2 wires.. (red and red/white). the other one is (red/yellow) but don't have any current... the buggy turn on if I jump the screws on the starting solenoid... and keep running until I turn it off from the switch.... any Idea what could be the problem??? I already replaced the solenoid and key Switch... Any help will be greatly appreciated...

Attachments:
IMG_20201109_175925969.jpg
IMG_20201109_175925969.jpg [ 2.54 MiB | Viewed 207 times ]
IMG_20201109_180318802.jpg
IMG_20201109_180318802.jpg [ 2.86 MiB | Viewed 207 times ]

Author:  MaxP [ Tue Nov 10, 2020 1:21 am ]
Post subject:  Re: Kandi 150cc ignition starting issue

Remove the plug from the solenoid, the one that goes to the ignition switch. The plug should have 12 volts DC when the key is at the start position. If you have nothing or less than 12 volts, mean you have a bad wire, most likely the ground is bad.

Author:  Mayito88 [ Tue Nov 10, 2020 8:37 am ]
Post subject:  Re: Kandi 150cc ignition starting issue

How can I find out which one is the ground on the ignition switch? Could it be the red/yellow wire?

Author:  MaxP [ Tue Nov 10, 2020 1:54 pm ]
Post subject:  Re: Kandi 150cc ignition starting issue

There's no ground on the ignition switch.

What I mean is the plug from the solenoid. There's 2 wires coming to engage the solenoid, when you turn the ignition switch to the start position, those 2 wires should have 12 volts DC on them.

Author:  Mayito88 [ Tue Nov 10, 2020 9:09 pm ]
Post subject:  Re: Kandi 150cc ignition starting issue

Well I checked the 2 wires as you suggested.. and find out only 1 wire the red/yellow has current and the one that comes from the brake switch (green/yellow) doesn't... And also on the brake switch next to the (green/yellow) one is a black wire.. I follow that one and goes to the switch... That one has current.... I changed the brake switch and nothing happened. 😒

Attachments:
IMG_20201110_180756841.jpg
IMG_20201110_180756841.jpg [ 3.45 MiB | Viewed 174 times ]

Author:  MaxP [ Wed Nov 11, 2020 5:54 pm ]
Post subject:  Re: Kandi 150cc ignition starting issue

You can check if the brake switch work by pushing the brake pedal, if it work, the brake light will be on. If the brake light don't come on, it mean you have a bad switch OR the light is burned. Depending on how your wiring is done on your machine, if one or the other do not work, you won't be able to start your machine.

You can also unplug your battery, positive and negative, and do a continuity test between the ground from the solenoid and the ground you remove from the battery. From what you say, when you push the brake pedal, it should ground the solenoid to the ground from the battery. But you might also have a relay somewhere under the dash that need power to ground the brake switch.

The biggest problem is, every machine wiring is slightly different depending on the manufacturer, without doing all test, it's hard to say how your wiring is working now.

In the video, link under, I do not include pushing the brake pedal to start your machine. Some machine came with that protection and some didn't. It depend on the driver, if you have young kid driving, this is a good thing to keep but if only adult drive it, not so much.

I did a video on YouTube for the basic wiring.
https://youtu.be/4U1ZulC22Zc

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/