It is currently Tue Jan 25, 2022 6:12 am



Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: NEW to karting
PostPosted: Fri Oct 29, 2021 10:13 am 
Offline
Probie

Joined: Fri Oct 29, 2021 9:30 am
Posts: 3
Location: Northern Pennsylvania
Hello everyone, I am new to this so this is a longer post with background info. I have a Tomberlin Crossfire 150 and cannot get it running correctly. Starts and idles fine with or without filter on. I can get WOT about 7440 RPM's without filter but minute I put any filter on it drops to about 4400 RPM'S. I have completed the following. Replaced top end, adjusted valves, cleaned carburator, set to 1 1/2 to 2 turns back on fuel/air mixture screw, adjusted idle to 1500 RPM's,adjusted float, no clogs in any jets, replaced coil and spark plug, replaced petcock without a vacuum line, has new gas, replaced fuel lines, tried Uni Filter and Cone Shape performance paper filters, still loses RPM's. Cannot locate replacement box or filter for this model. Tested for Vacuum leaks cannot find any. Don't know what I am missing, can it be the CDI? Only thing I haven't replaced, but starts easily and idles great. Confused, any help would be appreciated. Does this model need the petcock with the vacuum line to run correctly and the original air box and filter? Thinking of replacing the carb next but minga! Any help would be greatly appreciated. Thanks.


Top
 Profile  
 
 Post subject: Re: NEW to karting
PostPosted: Fri Oct 29, 2021 11:01 am 
Offline
Admin
User avatar

Joined: Wed Nov 28, 2007 2:21 am
Posts: 17959
Images: 24
Location: Pacific NW
Do you have a 6-8" intake runner between the carburetor and air filter? What size main jet are running - It should be 120-125 for a cold air intake.

_________________
09 Joyner SandViper 250
57 VW Transport 1200 (Buggified)


Top
 Profile Personal album  
 
 Post subject: Re: NEW to karting
PostPosted: Fri Oct 29, 2021 12:55 pm 
Offline
Probie

Joined: Fri Oct 29, 2021 9:30 am
Posts: 3
Location: Northern Pennsylvania
PGH, thank you for the quick response. Running 6 to 7" intake runner, but have to check the main jet size. I don't know if this was the original carb or not. Does the slow pilot assembly have to be a certain size as well? I don't know if any other jet modificatons have been done on this carb or not. Do the slow pilot and main jets have to match somehow? I will order a package of jets and mess around but if you know what combination/specs go together then I will start there. Thanks


Top
 Profile  
 
 Post subject: Re: NEW to karting
PostPosted: Sat Oct 30, 2021 12:19 am 
Offline
Admin
User avatar

Joined: Wed Nov 28, 2007 2:21 am
Posts: 17959
Images: 24
Location: Pacific NW
The slow jet gets you up from idle before the main starts to kick in. The jets are additive, so if you increase the pilot you may need to reduce the main. Is your fuel enricher working? Measure the needle and then apply 12VDC to it and measure it again after 5 minutes. If the needle has not extended, you will be running rich all the time and the filter may be enough restriction that it does not want to run at all. The enricher may be powered by AC directly off the stator or through ignition switched DC if you find manually applying power does extend the needle.

_________________
09 Joyner SandViper 250
57 VW Transport 1200 (Buggified)


Top
 Profile Personal album  
 
 Post subject: Re: NEW to karting
PostPosted: Thu Nov 18, 2021 7:32 pm 
Offline
Probie

Joined: Fri Oct 29, 2021 9:30 am
Posts: 3
Location: Northern Pennsylvania
PGH wrote:
The slow jet gets you up from idle before the main starts to kick in. The jets are additive, so if you increase the pilot you may need to reduce the main. Is your fuel enricher




working? Measure the needle and then apply 12VDC to it and measure it again after 5 minutes. If the needle has not extended, you will be running rich all the time and the filter may be enough restriction that it does not want to run at all. The enricher may be powered by AC directly off the stator or through ignition switched DC if you find manually applying power does extend the needle.


I believe my enricher is working, because it fires right up and runs great even after running about 10 minutes. I have replaced the main jet too a 130 and the small pilot jet to a 32. When I give full throttle I get about 6100 rpms, but it stalls when I let off the gas and I have to restart it then pump the gas to get it back to full throttle. I am using a Uni Filter, using the recommended main jet, so I am guessing that I have to get the correct combination of Main Jet and small pilot to get it running correctly, at least I got it running better with the filter on. Also when I completely turn the fuel/mixture screw in all the way the engine sill runs. Maybe the fuel/mixture screw is broken making it run rich all the time. It did not appear to be broken so maybe there is a gasket on the screw that is worn, just guessing. Any suggestions would be appreciated.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group

blackLevel designed by GrafsS



phpBB SEO
© Buggynews.com - All Rights Reserved