It is currently Sat Jul 11, 2020 7:56 am



Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: Carter 150 Ignition Prob!
PostPosted: Thu May 21, 2020 12:10 am 
Offline
Probie

Joined: Thu Apr 09, 2020 12:51 am
Posts: 6
Greetings all,
My recent aquisition a Carter 150 buggy has me puzzled. Leaving a friends house, I turned the key and nothing, turned it off and back and it started like normal. The next stop I made it did nothing upon trying to start.
I jumped the solenoid and restarted the buggy. I had to turn the key on to jump the start but that is all the key did was ign on, no lights, no horn or turn signals.
Now i try jumping the solenoid and no nothing, Any ideas?
Thanks


Top
 Profile  
 
 Post subject: Re: Carter 150 Ignition Prob!
PostPosted: Thu May 21, 2020 9:29 am 
Offline
Admin
User avatar

Joined: Wed Nov 28, 2007 2:21 am
Posts: 17724
Images: 24
Location: Pacific NW
Your ignition switch contacts are failing. Either replace it with the same or with a marine key switch.

_________________
09 Joyner SandViper 250
57 VW Transport 1200 (Buggified)


Top
 Profile Personal album  
 
 Post subject: Re: Carter 150 Ignition Prob!
PostPosted: Thu May 21, 2020 12:23 pm 
Offline
Probie

Joined: Thu Apr 09, 2020 12:51 am
Posts: 6
Thanks, I will get a marine switch and try it out today.


Top
 Profile  
 
 Post subject: Re: Carter 150 Ignition Prob!
PostPosted: Fri May 22, 2020 2:40 am 
Offline
Probie

Joined: Thu Apr 09, 2020 12:51 am
Posts: 6
Well I immediately went out and got the ignition switch didn't work still the same I wonder if my CD I took a crap


Top
 Profile  
 
 Post subject: Re: Carter 150 Ignition Prob!
PostPosted: Thu Jun 11, 2020 7:43 am 
Offline
Initiated
User avatar

Joined: Sat Dec 24, 2005 2:51 pm
Posts: 76
Location: Moundsville, West Virginia
If you haven't already, I'd check the battery connections, then the solenoid connections and any ground connections. I also like to use a little dielectric grease on all my buggy's electrical connections to help prevent corrosion. Good luck!

_________________
"I wish there was a way to tell you're in the good old days, before you've actually left them."


Top
 Profile  
 
 Post subject: Re: Carter 150 Ignition Prob!
PostPosted: Thu Jun 11, 2020 11:39 pm 
Offline
Probie

Joined: Thu Apr 09, 2020 12:51 am
Posts: 6
Thanks at the good place to start I thought the battery was good but it's corrupt so I'm going to check that and there's a couple of connections under the dashboard but thanks for the advice and I'll keep you posted thanks what do you think


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group

blackLevel designed by GrafsS



phpBB SEO
© Buggynews.com - All Rights Reserved